Humphrey Acuitus 5015 takes 40 minutes to warm up!

on December 2nd, 2011 | Filed under Optoblog, Reviews

The Humphrey Acuitus 5015 autoRfx/AukoK has been the most accurate autoRfx that I’ve worked with, but for a while, it’s been taking 20-30 minutes to warm up. No big deal because I get to work 20 minutes early anyway; however, for the last week it’s been taking 40-45 minutes to warm up!

I read that Humphrey stopped supporting it in 2009. Does anyone know why it would take an autorefractor 45 minutes before it stops snowing on the viewfinder video and allows you to begin using it?

Tags: ,

5 Comments

5 Responses to “Humphrey Acuitus 5015 takes 40 minutes to warm up!”

  1. John Himes says:

    The fact that your video board is “snowing” means some degradation of some components on the video board. I have been repairing this problem and countless others for three years now.

  2. marcelo ribeiro says:

    Well, my Acuitus 5010, starts showing a message CMOS Battery Low.How can i replace this battery if it´s possible.I buy a new one, and stop work that unit.Sometimes, i left this unit on for a time(long time), and so i turn off and on again.So the Acuitus run.If anybody can help=me my e-mail is memoinstal@bol.com.br

  3. Juan Carlos Gutierrez says:

    I have a acuitus 5015, sends this message, CMOS CHECKSUM ERROR – DEFAULT LOADED.
    already changed the internal battery and this message appears again, you can help me?
    I live in Guadalajara Jalisco Mexico, thanks.